VoIP movistar fibra y asterisk

Esta vez, configuraremos la voip de movistar en nuestro asterisk.

Movistar, con la fibra, nos ofrece un servicio VoIP vía la ONT….. si nos conformamos con usarlo tal cual, pues perfecto, pero si tenemos en la oficina o en casa un asterisk, la mejor manera de aprovecharlo, es configurar la voIP en nuestra PBX sin necesidad de usar conversores.

Partimos que tenemos la vlan 3 configurada en nuestro router y obtenemos la IP por DHCP (una 10.x.x.x)

usuario : NúmeroDeTeléfono
password: NúmeroDeTeléfono
proxy : 10.31.255.134
puerto : 5070

los datos del proxy, si googleamos un poco se pueden obtener, pero la configuración no…..

Primero de todo, necesitamos la cadena del register para el sip.conf


register => 9xxxxxxxx@telefonica.net:9xxxxxxxx@10.31.255.134:5070/9xxxxxxxx

Y ahora la definición del peer:

[VOMISTAR]
type =peer
fromuser=9XXXXXXXX
secret =9XXXXXXXX
fromdomain=telefonica.net
host =telefonica.net
callerid = "" <9XXXXXXXX>
outboundproxy=10.31.255.134:5070
port =5070
nat =force_rport,comedia
insecure=port,invite
dtmfmode=auto
disallow=all
allow =ulaw
allow =alaw
context =llamadas_entrantes

Una vez hecho ésto y con el correspondiente reload……. al hacer un sip show registry:


processpbx*CLI> sip show registry
Host dnsmgr Username Refresh State Reg.Time
10.31.255.134:5070 N 9xxxxxxxx@te 55 Registered Wed, 24 Jun 2015 23:09:28
1 SIP registrations.

A partir de aquí, ya es cosa nuestra con el diaplan !!!! enjoy your fiber 🙂

Cisco 87x adsl pppoE

Aquí­ está el detalle de la configuración de un cisco 877 con adsl de telefónica, pppoE, ya sea ip dinámica o ip fija:

ip dhcp pool redLocal
import all
network 192.168.1.0 255.255.255.0
dns-server 80.58.61.254 80.58.0.33
default-router 192.168.1.1
domain-name lan.local

ntp server 130.206.3.166 prefer source Vlan1

interface ATM0
mtu 1492
no ip address
ip nat outside
ip virtual-reassembly
no ip route-cache
no ip mroute-cache
no atm ilmi-keepalive
pvc 8/32
encapsulation aal5snap
protocol ip inarp
pppoe-client dial-pool-number 1
!

interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!

interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname adslppp@telefonicanetpa
ppp chap password adslppp
ppp pap sent-username adslppp@telefonicanetpa password adslppp
!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip nat inside source list 100 interface Dialer1 overload
!

access-list 100 remark –> ACL NO NAT
access-list 100 permit ip 192.168.1.0 0.0.0.255 any