Cisco Pix 515e con movistar Futura

Esta entrada es otro apunte.

Hoy toca configurar un pix515e contra la ONT de movistar directamente, taggueando la vlan 6.

Para ello, damos por supuesto que tenemos un pix con 7.2.x y la ONT funcionando….

Dejamos los interfaces tal que :

!
interface Ethernet0
no nameif
security-level 0
no ip address
!
interface Ethernet0.6
vlan 6
nameif outside
security-level 0
pppoe client vpdn group telefonica
ip address pppoe setroute

Y creamos el pppoe con el user / pass de toda la vida:

vpdn group telefonica request dialout pppoe
vpdn group telefonica localname adslppp@telefonicanetpa
vpdn group telefonica ppp authentication pap
vpdn username adslppp@telefonicanetpa password adslppp

y el resto de Globals y nat’s, como siempre.

enjoy your firewall 😉

cisco 87x PPPoE II Parte

Desde el cambio, por parte de telefónica,  al protocolo pppoe en todas sus líneas, he tenido algún que otro inconveniente con los routers cisco. En varias ocasiones me ha pasado que colocaba el cisco 18xx o el  87x y los pc’s de la red no navegan, aunque tengan salida a internet.

Revisando los log’s y googleando un poco, encontré un parámetro que arregla ésto:

Interface Dialer 1

…..

ip tcp adjust-mss 1452
….

Recientemente, en un cisco 1841 con pppoE contra un teldat de telefónica, configurado sin nat, he tenido que ir probando valores hasta ver que no se fragmentaban paquetes….. será de tu ayuda en los routers cisco el comando “amigo” debug tcp..

Cisco 87x adsl pppoE

Aquí­ está el detalle de la configuración de un cisco 877 con adsl de telefónica, pppoE, ya sea ip dinámica o ip fija:

ip dhcp pool redLocal
import all
network 192.168.1.0 255.255.255.0
dns-server 80.58.61.254 80.58.0.33
default-router 192.168.1.1
domain-name lan.local

ntp server 130.206.3.166 prefer source Vlan1

interface ATM0
mtu 1492
no ip address
ip nat outside
ip virtual-reassembly
no ip route-cache
no ip mroute-cache
no atm ilmi-keepalive
pvc 8/32
encapsulation aal5snap
protocol ip inarp
pppoe-client dial-pool-number 1
!

interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!

interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname adslppp@telefonicanetpa
ppp chap password adslppp
ppp pap sent-username adslppp@telefonicanetpa password adslppp
!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip nat inside source list 100 interface Dialer1 overload
!

access-list 100 remark –> ACL NO NAT
access-list 100 permit ip 192.168.1.0 0.0.0.255 any