Forzar spa50x cambios por tftp

Otro apunte…. estos días ando liado cambiando configuraciones en los teléfonos de un cliente y, necesito forzar que el teléfono (en mi caso, un spa502g), se descargue de nuevo el fichero del TFTP para aplicar los cambios y verlo de nuevo registrado en mi asterisk, con las modificaciones.

Tengo los ficheros en el tftp de mi servidor debian, siendo la ruta tftp://spa$fichero_config.xml.

Abrimos el navegador y tecleamos como url:

http://10.0.1.71/admin/resync?tftp://10.0.1.5/spa$MA.xml

10.0.1.71 : Ip del teléfono
10.0.1.5 : Ip del tftp / asterisk
spa$MA.xml: el fichero de configuración que hayamos creado, que está basado en la cadena spa + la mac address del dispositivo y con la extensión XML

Y a seguir configurando 😉

OpenMeetings openLdap Backend

Hoy toca configurar el openMeetings contra el openLdap.

Suponemos que:

– nuestro dominio ldap es craem.net.
– El usuario de lectura es openmeetings y password openmeetings.
– los usuarios los tenemos en la ou usuarios.
– Nuestro servidor ldap es: ldap.craem.net

Editamos el fichero:

/usr/lib/red5/webapps/openmeetings/conf/om_ldap.cfg

Y lo dejamos tal que:

# en nuestro caso es openLdap, con AD de micro$oft no acaba de ir bien
ldap_server_type=OpenLDAP
# la url de nuestro servidor
ldap_conn_url=ldap://ldap.craem.net:389
# la sintaxis es diferente, en vez del = es :
ldap_admin_dn=CN:openmeetings,DC:craem,DC:net
ldap_passwd=openmeetings
# ou donde buscamos los usuarios
ldap_search_base=CN:usuarios,DC:craem,DC:net
field_user_principal=uid
ldap_auth_type=SIMPLE
# sincronizamos los usuarios / pass, con la bbdd de openmeetings
ldap_sync_password_to_om=yes
# Ldap user attributes mapping
# Set the following internal OM user attributes to their corresponding Ldap-attribute
ldap_user_attr_lastname=sn
ldap_user_attr_firstname=givenName
ldap_user_attr_mail=mail
ldap_user_attr_street=streetAddress
ldap_user_attr_additionalname=description
ldap_user_attr_fax=facsimileTelephoneNumber
ldap_user_attr_zip=postalCode
ldap_user_attr_country=co
ldap_user_attr_town=l
ldap_user_attr_phone=telephoneNumber

Entramos como administrador al openmeetings y en la pestaña administration y ldap, ponemos el fichero que acabamos de modificar, tal que:

OpenMeetings OpenLDAP backend

Enjoy 😉

Sustituir router vodafone / comunitel con VoIP por cisco 827, 17xx o 18xx

Esto es una config que tenía hace tiempo.

Comunitel o ahora vodafone / tele2, cuando instalan un ADSL, los teléfonos tienen que ir conectados al router ADSL, con lo que es, a la práctica, VoIP.

Es un proveedor bastante cerrado y no es facil que te den los datos de conexión, pero tras mucho insistir los he conseguido.

El motivo de cambiarlo es que, necesito hacer una vpn y me gusta tener controlado los dos extremos, asi que procedemos y para ello necesitamos:

1º) usuario / password VoIP / ADSL
2º) IP’s gatekeepers
3º) Ip de VoIP

Partimos de la base siguiente:

1º) Dividen la conexión ADSL en 2 circuitos: circuito 1 datos, circuito 2 voz… así se aseguran que la voz tenga su caudal.

2º) En mi caso tenía un telsey con 2 bris (rdsi), así que la configuración para analógicos difiere un poco, aunque no mucho.

3º) La conexión es pppoA y o sé si es correcta, pero mí me ha funcionado.

4º) La voz, debe de ir “exclusivamente” por el circuito de voz, así que la deberemos encaminar con un route-map.

Una vez tenemos estos datos, vamos a configurar nuestro router, sabiendo que el circuito ATM es PPPoA. En mi caso he usado un cisco 1760:

Password:
zeusII#sh run
Building configuration…

Current configuration : 6752 bytes
!
! No configuration change since last restart
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname zeusII
!
boot-start-marker
boot-end-marker
!
enable password xxxxxxxxxx
!
no aaa new-model
memory-size iomem 25
clock timezone ESPANA 1
clock summer-time ESPANA recurring last Sun Mar 2:00 last Sun Oct 3:00
tdm clock bri-auto
voice-card 2
!
voice-card 3
!
ip cef
!
!
!
!
no ip domain lookup
ip domain name dominio.net
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
isdn switch-type basic-net3
!
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
h323
!
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g729r8
!
!
!
!
!
translation-rule 1201
Rule 1 ^0 12010
Rule 2 ^1 12011
Rule 3 ^2 12012
Rule 4 ^3 12013
Rule 5 ^4 12014
Rule 6 ^5 12015
Rule 7 ^6 12016
Rule 8 ^7 12017
Rule 9 ^8 12018
Rule 10 ^9 12019
!
!
!
!
!
!
interface Loopback0
ip address ip.de.voip 255.255.255.255
ip policy route-map TRAFICO_VOIP
h323-gateway voip interface
h323-gateway voip id gatekeeper1 ipaddr ip.gatekeeper.1.voip 1719 priority 126
h323-gateway voip id gatekeeper2 ipaddr ip.gatekeeper.2.voip 1719
h323-gateway voip h323-id userVoIP@bcn.comunitel.es$PASSWORD
h323-gateway voip bind srcaddr ip.de.voip
!
interface ATM0/0
no ip address
no ip redirects
no ip proxy-arp
load-interval 30
no atm ilmi-keepalive
bundle-enable
dsl operating-mode ansi-dmt
hold-queue 224 in
!
interface ATM0/0.1 point-to-point
description CIRCUITO_SOLO_INTERNET
pvc datos 0/33
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface ATM0/0.2 point-to-point
description CIRCUITO_VOIP
bandwidth 256
ip unnumbered Loopback0
pvc voz 0/34
cbr 448
inarp 1
no ilmi manage
encapsulation aal5snap
!
!
interface FastEthernet0/0
ip address 192.168.1.254 255.255.255.0
ip nat inside
no ip redirects
no ip proxy-arp
ip nbar protocol-discovery
ip virtual-reassembly
speed 100
full-duplex
no cdp enable
hold-queue 100 out
!
interface BRI3/0
no ip address
isdn switch-type basic-net3
isdn overlap-receiving
isdn protocol-emulate network
isdn layer1-emulate network
isdn spid1 num.telefono.linea
isdn caller num.telefono.linea
isdn incoming-voice voice
isdn skipsend-idverify
line-power
!
interface BRI3/1
no ip address
isdn switch-type basic-net3
isdn protocol-emulate network
isdn layer1-emulate network
isdn incoming-voice voice
isdn skipsend-idverify
line-power
!
interface Dialer1
ip address IP.PUBLICA.O.DHCP
ip nat outside
ip nbar protocol-discovery
ip virtual-reassembly
encapsulation ppp
load-interval 30
dialer pool 1
no cdp enable
ppp authentication chap callin
ppp chap hostname usuario.adsl@iservicesmail
ppp chap password passwordadsl

ip nat inside source list 101 interface dialer 1 overload
ip local policy route-map TRAFICO_VOIP
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
no ip http server
no ip http secure-server

access-list 23 permit 192.168.0.0 0.0.0.255
access-list 100 remark — Marcado y routing del trafico de VoIP
access-list 100 permit ip any any dscp cs5
access-list 100 permit ip host ip.de.voip.solo any
access-list 101 remark –> acl permitirNAT
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!
route-map TRAFICO_VOIP permit 10
match ip address 100
set ip precedence critical
set interface ATM0/0.2
!
!
!
control-plane
!
!
!
voice-port 2/0
input gain 8
output attenuation 14
echo-cancel coverage 32
cptone ES
timeouts interdigit 5
description PUERTO_0_FXS
station-id number numero.telefono
caller-id enable
!
voice-port 2/1
input gain 6
output attenuation 14
echo-cancel coverage 32
cptone ES
timeouts interdigit 5
description puerto_1_FXS
caller-id enable
!
voice-port 3/0
output attenuation 7
echo-cancel coverage 32
compand-type a-law
cptone ES
timeouts interdigit 5
description PUERTO_0_RDSI_
!
voice-port 3/1
output attenuation 7
echo-cancel coverage 32
compand-type a-law
cptone ES
timeouts interdigit 5
description PUERTO_1_RDSI_
!
!
!
!
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
huntstop
destination-pattern numero.telefono
incoming called-number .
direct-inward-dial
port 2/0
!
dial-peer voice 1201986 voip
description SALIENTES NACIONALES-MOVILES 9 DIG PUERTO FAX Y ENTRANTES FAX
huntstop
destination-pattern numero.telefono
translate-outgoing called 1201
no modem passthrough
voice-class codec 1
voice-class source interface Loopback0
session target ras
incoming called-number .
fax rate disable
fax protocol none
ip qos dscp cs5 media
ip qos dscp cs5 signaling
no vad
!
dial-peer voice 12011234 voip
description SALIENTES RESTO FAX
huntstop
destination-pattern .T
translate-outgoing called 1201
no modem passthrough
voice-class codec 1
voice-class source interface Loopback0
session target ras
fax rate disable
fax protocol none
ip qos dscp cs5 media
ip qos dscp cs5 signaling
no vad
!
dial-peer voice 2 pots
incoming called-number .
direct-inward-dial
port 3/0
!
dial-peer voice 3 pots
incoming called-number .
direct-inward-dial
port 3/1
!
num-exp 1201090 1201333
gateway
timer receive-rtp 1200
!
!
line con 0
line aux 0
line vty 0 4
access-class 23 in
password password
login
!
ntp clock-period 17208156
ntp server hora.rediris.es source FastEthernet0/0 prefer
end

zeusII#

Instalando OwnCloud en Debian Squeeze

Otro apunte para tener nuestra propia nube con el fantástico producto openSource, OwnCloud.

Instalamos los paquetes básicos en nuestro debian:

# apt-get install apache2 php5 php-pear php-xml-parser php5-sqlite php5-json sqlite php5-mysql mp3info curl libcurl3 libcurl3-dev php5-curl zip php5-gd

Ahora, para poder abrir los .tar.bz2:

# apt-get install bzip2

Y descargamos OwnCloud:

# cd /usr/src
# wget -c http://download.owncloud.org/releases/owncloud-4.0.4.tar.bz2
# tar xvf owncloud-4.0.4.tar.bz2
# mv owncloud /var/www/owncloud

Ahora modificamos los permisos de la carpeta /var/www/owncloud :

# chown -R www-data:www-data /var/www/owncloud

Reiniciamos apache:

# /etc/init.d/apache2 restart

Ahora, iniciamos nuestro navegador y finalizamos la instalación:

Ponemos un nombre de usuario + password y le damos al botón de completar la instalación. Elegimos SqlLite o MySQl y el directorio de instalación, en nuestro caso /var/www/owncloud

Y ya tenemos nuestra propia nube instalada 😉

Configurando ntp en debian

Otro apunte. Siempre me dejo por configurar el reloj cuando instalo servidores linux y nunca me acuerdo de documentarlo.

Instalamos los servicios ntp, ntpdate:

# apt-get install ntp ntpdate

Y en un rato tendremos los paquetes instalados. Ahora toca configurar el source; personalmente me gusta el de hora.rediris.es, ya que time.windows.com, no acaba de ir conmigo 😉

Editamos el fichero /etc/ntp.conf

/etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help

driftfile /var/lib/ntp/ntp.drift

# Enable this if you want statistics to be logged.
#statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable

# You do need to talk to an NTP server or two (or three).
#server ntp.your-provider.example

# pool.ntp.org maps to about 1000 low-stratum NTP servers. Your server will
# pick a different set every time it starts up. Please consider joining the
# pool:
server hora.rediris.es
server 0.debian.pool.ntp.org iburst dynamic
server 1.debian.pool.ntp.org iburst dynamic
server 2.debian.pool.ntp.org iburst dynamic
server 3.debian.pool.ntp.org iburst dynamic

Y ponemos nuestro servidor preferido, en mi caso, hora.rediris.es

Y ahora a reiniciar el servicio para aplicar cambios:

# /etc/init.d/ntp restart

Las cajas ACME :: el desencanto ::

Esto no es un artículo habitual, sinó más bien una história que he vivido de cerca y tira por tierra la super imagen de marca de una multinacional, la gran marca ACME.

Todo aquí es figurado… marcas, nombres, personas…. pero la história es cierta, muy cierta; estamos en un país de pandereta y hasta las grandes marcas, bajan a la categoría -3, por culpa de los malos gestores / jefes, que contratan sin tener en cuenta el currículum.

A mí, me gustan bastante las cajas de música marca tux (la gente que me conoce lo sabe), pero las marca acme, no me desagradan…. en casa tengo bastantes cajas tux, alguna acme y una coyote…. hay que probar / tener de todo.

Nos remontamos a hace unos 6 meses:

Hace unos meses, compré una super caja ACME 7.0: un pastón (600 leuros de los güenos)… muy bonita, elegante y discreta. A las 5 de la mañana, delante de la tienda, como buen freak, para comprar una de las primeras, ante un despliegue de medios impresionante y, la verdad, quedé bastante sorprendido de la capacidad de márketing.

Varios días con la caja y todo perfecto… abría la tapa y se escuchaba música, que es en el fondo para lo que sirve, pero al cabo de unos días, al tener la tapa levantada, la música dejaba de sonar o, se quedaba sin volumen; extrañado, llamo al que provee la música y le comento:

– La música no se oye o deja de sonar.. puede ser que sea de la música ??

Me responde la amable operadora:

– Prueba la generadora de música en otra caja y me comentas, pero las cajas ACME, no son tan buenas como la gente piensa.

Incrédulo de mí, dudo, pero lo decido probar. Meto la generadora con un conversor en otra caja que tengo en casa y todo perfecto; la música suena y no se corta.

Decido ir a llevar la caja a la gran CASA ACME: me acerco un viernes por la tarde y estaba a petar. Me atiende una amable maga y le comento mi problema… mira, tengo esta caja y pasa que se corta bla bla bla bla …. y me dice la maga: tienes que pedir hora con un “GENIO”, que te resolverán el problema. Te apunto para mañana sábado a las 18:00.

Yo, sorprendido, pienso… “ostia, voy a tener el privilegio de hablar con un GENIO, guaaay”… yo me considero mago de nivel 20, pero no un GENIO.

Aparezco el sábado por la tarde con la caja intacta y su factura de 600 leuros por la tienda… (a petar de gente) me acerco a una de las magas que trabajan allí y le comento que tengo hora con un GENIO. Me pongo a la cola y veo varias GENIO (muy guapas, por cierto), resolviendo problemas con cajas a otras personas y me dió buena impresión.

Reconozco que tenía unas perspectivas bastante altas, y fue eso la culpa de fatal desenlace.

Me toca con la SUPUESTA GENIO, normal, jovencita y maja. Le explico mi problema:

“Hola mira, tengo esta caja de música ACME 7.0 y la música se corta o se va el volumen”

Se me queda mirando y me dice….

– Si, es posible, el condensador de fluzo, fluzea y produce que el volumen de la música desaparezca… esto, bueno, podría ser… quizás… a veces, patatim, patatam…….

Total, que estaba la GENIO más perdida que Chuck Norris en la casa de la Pradera, así que le corto la conversación:

– Oye GENIO, que a mí no me expliques cuentos del condensador de fluzo…… a mí eso no me cuela… este cuento no es para mí. O sale alguien que sepa de verdad de cajas o me la cambias directamente sin rechistar.

Total, que frunce el ceño, me pide la factura y me hace el cambio sin rechistar…..

– Joder, pensé yo….. si esto es un GENIO, no quiero saber lo que los magos sabrán en esta tienda.

Me voy para casa con la caja nueva o remanufacturada y todo normal… felíz LIKE a perdíz.

Al cabo de unos meses, sale una oferta de trabajo para “GO-GO de ventas” en una nueva tienda de la casa ACME y a una persona cercana le comento… oye, pon el currículum en “buenJOB” y a ver si suena la flauta.

La persona cercana, Francisquita para los amigos, rellena el currículum y lo pone en BuenJOB….. ACME es una buena marca y a Francisquita le gusta mucho ACME, así que había ilusión, mucha ilusión, a parte de tener mucha experiencia como “GO-GO de ventas” en “CAJAS PANDORA”.

Francisquita, lleva 6 años como GO-GO de ventas en Pandora, tiene 2 carreras universitaras y un nivel de inglés aceptable, que se podría reforzar, yendo a las clases de CCC.

Pasan los días y recibe un email de Manolito Gafotas, el responsable de RRHH de ACME. Le responde el email y al día siguiente la llama directamente al móvil para hacer una entrevista.

Nosotros sabíamos que uno de los jefes de ACME, era antíguo trabajador / jefe de PANDORÍN y conocía a Francisquita, así que a priori, ya sabe como trabaja….. vamos bien.

Francisquita, more nervious than a Flan, se dirige a la entrevista el día “D”, hora “H”, que se realiza en la famosa “Charcutería Manolo”, ubicada en un céntrico lugar de españistán. Entra en la entrevista y se encuentra a Manolito Gafotas, tal y como habían quedado y a Rompetechos, que era el antíguo jefe en “PANDORÍN”.

La entrevista fluye amablemente y con buena impresión; Francisquita para la ocasión, se viste de primera comunión, con su traje de marinerito y zapatos de charol. Durante la entrevista, le preguntan aspectos de “Porqué quieres cambiar”, “Porqué quieres trabajar en ACME” y poco acerca de las capacidades laborales…. extraño, pero cierto.

Una vez acabada la entrevista, se encuentra bajando las escaleras de la “Charcutería Manolo” a 2 conocidas que optan al mismo puesto:

– Daisy, que es una joven guapa, sin experiéncia y trabajadora en CAJAS PANDORA, estando por debajo de Francisquita a nivel laboral. Menos estudios (tiene la etiqueta de anís de mono), nada de inglés y con facilidad a ponerse a llorar con situaciones de estress, que serán habituales en las tiendas ACME.

– Eusebia, con más experiencia, trabajadora y la posible competencia de Francisquita….cosa que nos incomoda un poco.

Por Daisy no tenemos que temer nada…. es una yogurina, aunque tiene la baza de su físico y es muucho más joven.

Al cabo de unos días, recibe un email de Manolito Gafotas, en el cual le dicen que han desestimado su candidatura, ya que han recibido numerosos currículums de gente muy preparada. Nosotros pensamos… ostia, es para un puesto de responsabilidad y me imagino que habrán recibido miles de currículums, pero yo seguía con la mosca detrás de la oreja.

Pasan los días y Francisquita se entera de que han cogido a Daisy…… inaceptable….. prefieren para un puesto de esa envergadura a una chica guapa sin experiencia y maleable que a otras mucho más formadas, maduras y más experientadas.

A partir de entonces, ACME ha perdido un comprador, fan y freak. He dicho.

Cisco 87x con movistar futura

Otro apunte, para configurar un cisco 87x con la fibra de movistar:

Current configuration : 5274 bytes
!
! Last configuration change at 13:12:21 ESPANA Thu Jul 5 2012
! NVRAM config last updated at 13:12:21 ESPANA Thu Jul 5 2012
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password password
!
no aaa new-model
clock timezone ESPANA 1
clock summer-time ESPANA recurring last Sun Mar 2:00 last Sun Oct 3:00
!
!
dot11 syslog
ip source-route
!
!
!
ip dhcp pool redLocal
import all
network 192.168.1.0 255.255.255.0
dns-server 8.8.8.8
default-router 192.168.1.254
domain-name lan.local
!
!
ip cef
no ip domain lookup
ip domain name lan.local
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
archive
log config
hidekeys
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
description FIBRA MOVISTAR
switchport access vlan 6
switchport mode trunk
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description CONNECTED TO LOCAL LAN
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Vlan6
description VLAN DATOS TELEFONICA
no ip address
ip nat outside
ip virtual-reassembly
no ip route-cache cef
no ip route-cache
ip tcp adjust-mss 1452
pppoe enable group global
pppoe-client dial-pool-number 1
!

interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname adslppp@telefonicanetpa
ppp chap password 0 adslppp
ppp pap sent-username adslppp@telefonicanetpa password 0 adslppp
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
ip nat inside source list 100 interface Dialer1 overload
!
access-list 23 permit 192.168.0.0 0.0.255.255
access-list 100 remark –> ACL NO NAT
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
access-class 23 in
password password
login
!
scheduler max-task-time 5000
ntp server 130.206.3.166 prefer source Dialer1
end