Probando Acrobis SoftPhone con android 2.1

Aquí está la review del sofphone de la gente de Acrobis para Android.

Primero de todo, decir que el softphone está en fase beta. Envié un email para ofrecerme como betatester y, durante unos días lo he estado probando…. tengo pendiente comprar la licencia de g729 para poder sacar todo el rendimiento.

Las primeras impresiones no han sido buenas; frecuentemente, mientras hago una llamada desde el soft, se queda colgado y se cierra la aplicación, pero le damos un voto de confianza; está en fase beta y lo tienen que mejorar:

Empezamos con la configuración:

1º) Instalamos el soft, tras mandar el email pertinente, nos genera un código que hemos de reenviarlo por email.. cerramos aplicación, volvemos a abrir y ya lo tenemos operativo… nos vamos a settings / SIP accounts y añadimos una:

… añadimos la cuenta :

En el botón de Advanced Settings, podemos seleccionar el Stun Server, los códecs para wifi / 3G…

Y una opción que me ha sorprendido bastante, es que soporta sip en:
– UDP
– TCP
– TLS (sips)
– TLS (sip)

Yo, de momento sólo puedo probar el sip sobre UDP… hasta que tenga montada la maqueta de openSips y me empolle a fondo el protocolo sip, no voy a abarcar más.

Una vez definido todo, nos queda tal cual la pantalla:

Salimos de la config, y nada, a ahorrar en llamadas:

Las pruebas, tanto en g711a y gsm han sido buenas; calidad de voz en wifi y 3G, similar a sipDroid.

Esperemos que se solucionen los problemas de crash y estoy seguro que será un buen producto.

Configurando QoS para VoIP (Asterisk) cisco 87x DSL

El tema del QoS es muy importante si tenemos VoIP. Es posible que, si tenemos muy poco tráfico, no haga falta configurarlo, pero recomiendo encarecidamente configurarlo si no queremos que nos funcione mal. De todas maneras, las ADSL con lo que son y no hay milagros que valgan, pero si queremos que nuestras llamadas fluyan perfectamente, hay que configurarlo.

En las configuraciones generales, en un router, podemos asigar un ancho de banda simplemente o, asignar un ancho de banda con prioridad……. de nada sirve asignar un ancho de banda si luego los paquetes ip salen mezclados. Para ello, usaremos el comando priority en los routers.

El siguiente ejemplo, es un adsl de telefónica con PPPoE:


r877#sh run

Building configuration…
!
Version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname r877
!
boot-start-marker

boot-end-marker
!
logging message-counter syslog
enable password MIPASSWORD
!
!
!
clock timezone ESPANA 1 //PONEMOS EN ZONA HORARIA EL ROUTER //
clock summer-time ESPANA recurring last Sun Mar 2:00 last Sun Oct 3:00
!
!
dot11 syslog
ip source-route
!
!
!
ip dhcp pool redLocal // CONFIGURAMOS EL DHCP //
import all
network 192.168.1.0 255.255.255.0
dns-server 8.8.8.8 80.58.0.33
default-router 192.168.1.1
domain-name lan.local
!
!
no ip cef
no ip domain lookup

ip domain name lan.local
no ipv6 cef
ntp server 130.206.3.166 prefer source Vlan1 //el clock, el de rediris//
!
!
archive
log config
hidekeys

ip ssh version 1

class-map match-all voIp_Asterisk // definimos la class map para la voip//
match access-group 150 //el access-list 150 nos define lo que priorizamos
!
!
policy-map LLQ //definimos la policy-map
class voIp_Asterisk //cuál vamos a utilizar
priority 128 // reservamos 128 Kb’s de ancho de banda en priority //
!
!
interface ATM0
mtu 1492
bandwidth 320 // bandwitch para el atm; lo calculamos con la subida //
no ip address
ip nat outside
ip virtual-reassembly
no ip route-cache
no ip mroute-cache
no atm ilmi-keepalive
pvc 8/32
encapsulation aal5snap
protocol ip inarp
pppoe-client dial-pool-number 1
!
max-reserved-bandwidth 100
service-policy output LLQ // aplicamos el QoS
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!

interface Dialer1
mtu 1492
bandwidth 320
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname adslppp@telefonicanetpa
ppp chap password adslppp
ppp pap sent-username adslppp@telefonicanetpa password adslppp
max-reserved-bandwidth 100
service-policy output LLQ
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
!
ip nat inside source list 100 interface Dialer1 overload
!
access-list 80 remark — Lista para definicion de Direcciones que permitimos interrogar por SNMP
access-list 80 permit 192.168.0.0 0.0.255.255
access-list 100 remark –> ACL NO NAT
access-list 100 permit ip 192.168.21.0 0.0.0.255 any
access-list 150 remark –>ACL PRIORIZACION VOIP
access-list 150 permit udp any any eq 5060
access-list 150 permit udp any any range 10000 20000
access-list 150 permit udp any any eq 4569
!
snmp-server community MICOMUNIDAD RO 80
snmp-server location MICASA
snmp-server contact SOY@YO.COM
!
control-plane
!
banner login ^CCCCC
————————————————————————————————————————
Esta conectado a un equipo propiedad MANOLITO
El acceso a esta maquina o a las redes a las que se conecta esta prohibido si usted no tiene un permiso expreso.
El acceso no autorizado a la misma es ilegal y podria estar sujeto a penas civil es y/o criminales.
El acceso a este sistema esta siendo monitorizado y esta informacion podria ser utilizada en su contra ante la justicia.
Si no tiene permiso expreso del administrador de esta red, por favor, ABANDONE EL EQUIPO.
————————————————————————————————————————
^C
!
line con 0
no modem enable
line aux 0
line vty 0 4
password MIPASSWORD
!
scheduler max-task-time 5000
end
r877#

Las reglas siempre se tienen que aplicar lo más cerca del destino; en nuestro caso, el interface ATM.

Usuarios lerdos. Como aguantarlos y no morir en el intento

Hace unos días, me tocó atender a una usuaria de un cliente, que prácticamente acabó con mi paciencia. Para que se vea lo que tenemos que aguantar y que muchas veces, llenamos el cupo:

Conversación, de 1:30 horas:

Me llama para decirme que no puede iniciar la sesión en el servidor de Terminal; nos ponemos en antecedentes:

Yo ¿cual es tu nombre , para buscar tu usuario ??

Ella: Temporal

Yo: ¿Te llamas temporal ??

ella: … esto, no mari carmen lopez, pero es lo que escribo en el ordenador

Yo: Vale, en nombre de usuario tienes que poner mcarmen.lopez@zztopmaiden

Ella: zztopmaiden va con 1 o 2 zetas ??

Yo: esto….. el nombre de la tienda va con 1 o 2 Z ?? ¿ en las tarjetas que das, cómo va ??

ella: No lo sé, llevo 3 años y no me he fijado

Yo: va con 2 zetas

Ella: Vale….. lo estoy poniendo y no va

Yo: ¿Qué estás poniendo ??

Ella: pues lo que me has dicho: m.carmen.lopez@zztopmaiden

Yo: Te he dicho que es mcarmen.lopez@zztopmaiden

Ella: vale…… lo estoy poniendo y no va

Yo: Veo en el visor de sucesos que pones m.carmen.lopez@zztopmaiden, y te he repetido varias veces que es mcarmen.lopez@zztopmaiden

Ella: ….. lo siento, es que soy un poco torpe con el ordenador. Lo pruebo de nuevo…… sigue sin ir

Yo: Miro visor de sucesos y estás escribiendo : M.CARMEN.LOPEZ@zztopmaiden. Por favor, todo en minúsculas y sin el punto…

Ella: ¿ Qué es minúsculas ??….. perdón, perdón, estoy un poco nerviosa, ahora lo pruebo

Yo: ¿ Me estás hablando en serio ??

Ella: Sigue sin ir…. esto no va

Yo: Estás volviendo a poner m.carmen.lopez@zztopmaiden, por favor, escúchame y ponlo bien.

Ella: No, lo estoy poniendo como me dices….. uy!!!!, sí, es verdad, lo estoy poniendo mal. lo siento… pensarás que soy torpe.

Yo: no, no te preocupes, soy yo, que me expreso mal.

Ella: Puede ser, ya que no te entendía.

Yo: ya…. tranquila, estoy acostumbrado a gente como tú, pero estás batiendo records…

Ella: …. sigue sin ir.

Yo: Vale, te cojo el control remoto de la sesión…. verás que se mueven, por arte de magia las cosas solas.

Ella: …… no va

Yo: Vale, tengo el control remoto… me estás PONIENDO m.carmen.lopez@zztopmaiden POR FAVOR ESCUCHAME y pon lo que yo te diga…. m de madrid, c de casa a de alfa Y veo que en pantalla me está escribiendo… m de madrid, sí todas las letras.

Ella: Si que tengo que escribir cosas, antes no era tan difícil…

Yo: por favor, estás acabando con mi paciecia…. déjame a mí…. le cojo el control remoto y escribo en su pantalla: mcarmen.lopez@zztopmaiden

Ella: Ahhh, es así mi nombre de usuario ????

Yo: Pues sí, y ahora en la casilla de abajo escribe temporal

Ella: Mi nombre ???

Yo: Eso, si, tu nombre…….. y ya te funciona , adiós