Desactivar SIP ALG routers / Firewalls Cisco

Estos días me he encontrado en que algunos teléfonos que estaban detrás de NAT y fuera de la VPN se desregistraban y/o no podían recibir llamadas.

Tras mucho trastear con las configuraciones y googleando bastante, he encontrado una opción útil para deshabilitar todas las inspecciones posibles:

Cisco Routers IOS
no ip nat service sip udp port 5060

Cisco PIX 6.3.x
no fixup protocol sip 5060
no fixup protocol sip udp 5060

Con el tema de los Pix, me he llevado la sorpresa de que, las centralitas non SIP RFC compliant como las siemens, el teléfono es incapaz de registrase.

Configurar cisco 87x "encapsulado ethernet" YA.COM

RFC1483Bridge. Es la primera vez que me encuentro con este encapsulado….. los habituales son: – RFC 1483r –> típico de las conexiones antíguas de telefónica con ip fija – RFC 2516 —> PPPoE, típico de las las conexiones nuevas de telefónica, jazztel y algún otro que ahora no recuerdo – RFC 2364 —> PPP over ATM, típico de las conexiones de Sarenet, tele2 / comunitel y alguna más. – RFC 1483b –> Conexión típica ahora de ya.com xDDDDD Empezamos por lo típico: clock timezone ESPANA 1 clock summer-time ESPANA recurring last Sun Mar 2:00 last Sun Oct 3:00 ! ! dot11 syslog ip source-route ! ! ! ip dhcp pool redLocal network 192.168.x.x 255.255.255.0 domain-name tudominio.loquesea default-router 192.168.x.254 dns-server tudns no ip domain lookup ip domain name tudominio no ipv6 cef ntp server 130.206.3.166 prefer source Vlan1 bridge irb ! ! interface ATM0 bandwidth 320 no ip address ip nat outside ip virtual-reassembly no ip route-cache cef no ip route-cache no ip mroute-cache no atm ilmi-keepalive pvc 8/32 encapsulation aal5snap ! bridge-group 1 interface Vlan1 ip address 192.168.x.254 255.255.255.0 ip nat inside ip virtual-reassembly ! interface BVI1 ip address dhcp ip nat outside ip virtual-reassembly ! ip forward-protocol nd ip route 0.0.0.0 0.0.0.0 dhcp ip http server no ip http secure-server ip nat inside source list 100 interface BVI1 overload access-list 23 remark –> acl permitir telnet red local access-list 23 permit 192.168.0.0 0.0.255.255 access-list 100 remark –>ACL NAT access-list 100 permit ip 192.168.x.0 0.0.0.255 any bridge 1 protocol ieee bridge 1 route ip banner login ^CCCCCCCCC ———————————————————————————————————————— Esta conectado a un equipo propiedad de ……… El acceso a esta maquina o a las redes a las que se conecta esta prohibido si usted no tiene un permiso expreso. El acceso no autorizado a la misma es ilegal y podria estar sujeto a penas civil es y/o criminales. El acceso a este sistema esta siendo monitorizado y esta informacion podria ser utilizada en su contra ante la justicia. Si no tiene permiso expreso del administrador de esta red, por favor, ABANDONE EL EQUIPO. ———————————————————————————————————————— line vty 0 4 access-class 23 in password tupassword login

]]>

Configurar cisco 87x "encapsulado ethernet" YA.COM

Aquí tenéis el detalle de la configuración de un cisco 87x con adsl del proveedor ya.com, con encapsulado RFC1483Bridge.

Es la primera vez que me encuentro con este encapsulado….. los habituales son:

– RFC 1483r –> típico de las conexiones antíguas de telefónica con ip fija

– RFC 2516 —> PPPoE, típico de las las conexiones nuevas de telefónica, jazztel y algún otro que ahora no recuerdo

– RFC 2364 —> PPP over ATM, típico de las conexiones de Sarenet, tele2 / comunitel y alguna más.

– RFC 1483b –> Conexión típica ahora de ya.com xDDDDD

Empezamos por lo típico:

clock timezone ESPANA 1
clock summer-time ESPANA recurring last Sun Mar 2:00 last Sun Oct 3:00
!
!
dot11 syslog
ip source-route
!
!
!
ip dhcp pool redLocal
network 192.168.x.x 255.255.255.0
domain-name tudominio.loquesea
default-router 192.168.x.254
dns-server tudns

no ip domain lookup
ip domain name tudominio
no ipv6 cef
ntp server 130.206.3.166 prefer source Vlan1

bridge irb
!
!
interface ATM0
bandwidth 320
no ip address
ip nat outside
ip virtual-reassembly
no ip route-cache cef
no ip route-cache
no ip mroute-cache
no atm ilmi-keepalive
pvc 8/32
encapsulation aal5snap

!
bridge-group 1

interface Vlan1
ip address 192.168.x.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface BVI1
ip address dhcp
ip nat outside
ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 dhcp
ip http server
no ip http secure-server

ip nat inside source list 100 interface BVI1 overload

access-list 23 remark –> acl permitir telnet red local
access-list 23 permit 192.168.0.0 0.0.255.255
access-list 100 remark –>ACL NAT
access-list 100 permit ip 192.168.x.0 0.0.0.255 any

bridge 1 protocol ieee

bridge 1 route ip

banner login ^CCCCCCCCC

————————————————————————————————————————

Esta conectado a un equipo propiedad de ………
El acceso a esta maquina o a las redes a las que se conecta esta prohibido si usted no tiene un permiso expreso.

El acceso no autorizado a la misma es ilegal y podria estar sujeto a penas civil es y/o criminales.

El acceso a este sistema esta siendo monitorizado y esta informacion podria ser utilizada en su contra ante la justicia.

Si no tiene permiso expreso del administrador de esta red, por favor, ABANDONE EL EQUIPO.

————————————————————————————————————————

line vty 0 4

access-class 23 in
password tupassword
login