Cisco 87x adsl pppoE

Aquí­ está el detalle de la configuración de un cisco 877 con adsl de telefónica, pppoE, ya sea ip dinámica o ip fija:

ip dhcp pool redLocal
import all
network 192.168.1.0 255.255.255.0
dns-server 80.58.61.254 80.58.0.33
default-router 192.168.1.1
domain-name lan.local

ntp server 130.206.3.166 prefer source Vlan1

interface ATM0
mtu 1492
no ip address
ip nat outside
ip virtual-reassembly
no ip route-cache
no ip mroute-cache
no atm ilmi-keepalive
pvc 8/32
encapsulation aal5snap
protocol ip inarp
pppoe-client dial-pool-number 1
!

interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!

interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname adslppp@telefonicanetpa
ppp chap password adslppp
ppp pap sent-username adslppp@telefonicanetpa password adslppp
!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip nat inside source list 100 interface Dialer1 overload
!

access-list 100 remark –> ACL NO NAT
access-list 100 permit ip 192.168.1.0 0.0.0.255 any

Actualizando el kernel de linux / Debian

En esta ocasión, recupero los apuntes que tengo para recompilar el kernel de Linux / Debian.

Primero de todo, actualizamos

#apt-get update

Instalamos las dependencias necesarias

#apt-get install kernel-package libncurses5-dev fakeroot wget bzip2 build-essential

– Descargamos el kernel

#cd /usr/src
#wget http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.27.45.tar.gz

y lo descomprimo:

#tar -zxvf linux-2.6.27.45.tar.gz

Creamos un enlace simbólico:

# ln -s /usr/src/linux-2.6.27.45 /usr/src/linux

# cd linux

Copiamos la configuración actual del Kernel, para no dejarnos nada… por ejemplo, drivers de SATA, gráfica, etc…

#cd /boot

Copiamos el fichero config-2.6.x.x actual a la carpeta /usr/src/linux

Nos vamos a la carpeta del kernel para hacer las modificaciones:

#cd /usr/src/linux

Limpiamos, por si acaso hay algo anterior:

#make clean && make mrproper

Añadimos el nuevo kernel a las opciones de boot

#cp /boot/config-`uname -r` ./.config

Ahora, ejecutamos el config y seleccionamos las opciones que creamos oportunas:

#make menuconfig

Una vez acabado, nos vamos a construir los paquetes para instalarlos:

#make-kpkg clean
#fakeroot make-kpkg –initrd –append-to-version=-custom kernel_image kernel_headers

Nos vamos a tomar un café (o varios) y esperemos a que acabe. En función de la máquina puede tardar entre 30 minutos a 2 – 3 horas.

Una vez acabado, nos dejará 2 ficheros en /usr/src y procedemos a instalarlo:

#dpkg -i linux-image-2.6.23.12-custom_2.6.27.45-custom-10.00.Custom_i386.deb
#dpkg -i linux-headers-2.6.23.12-custom_2.6.27.45-custom-10.00.Custom_i386.deb

Rebotamos y listo !!!

Después del desastre….

Después del desastre, mi blog vuelve a estar en marcha. Antes lo tenía en un viejo pc y el disco duro dejó de funcionar…. y no tenía copias…. (si, sin copias…). Ahora he aprendido y lo tengo en una máquina virtual, que lo incluyo dentro de las tareas de copias diarias.

Para más detalles, el servidor es un DL 380 G5, con eSXI 5.0 y 6 máquinas más

Espero esta vez, que ante un desastre de hardware pueda recuperarlo sin más.